Results 1 to 2 of 2

Math Help - Something is wrong with my code

  1. #1
    Newbie
    Joined
    May 2009
    Posts
    21

    Something is wrong with my code

    HI

    I'm trying to make a graph with the following demands :

    h(t)=
    1 - |10*t| , |10*t| <= 1
    0 , |10*t| >=1

    -50 < σ< 50
    -100 < ω < 100

    X axe is ω
    Y axe is (σ+jω)*ω
    Z axe is |H(s)|
    I need to make a graph of |H(s)| (the absolute value) of the Laplace transform of h(t) , but I always get the
    wrong one (as showed in the attached files) . Please help me understand where is my mistake .

    thanks !!!
    [/B][/FONT]
    Last edited by new guy; June 29th 2009 at 02:49 AM.
    Follow Math Help Forum on Facebook and Google+

  2. #2
    Senior Member
    Joined
    Nov 2008
    Posts
    461
    Quote Originally Posted by new guy View Post
    Hi guys ,

    I'm trying to make a graph with the following demands :

    h(t)=
    1 - |10*t| , |10*t| <= 1
    0 , |10*t| >=1

    -50 < σ< 50
    -100 < ω < 100

    X axe is ω
    Y axe is (σ+jω)*ω
    Z axe is |H(s)|
    I need to make a graph of |H(s)| (the absolute value) of the Laplace transform of h(t) , but I always get the
    wrong one (as showed in the attached files) . Please help me understand where is my mistake .

    thanks !!!
    [/b][/font]
    Hi.
    I probably can't help you.

    But there is one little thing I don't understand.

    The code says:

    h(t):= A(10*t)

    So your function h(t) is equal to

    h(t)=
    1 - |10*t| , |10*t| <= 1
    0 , |10*t| >=1
    But you integrate h(t*10) - you use the function
    h(t) = 1-|10*10*t|, iff |10*10*t| <= 1 and
    h(t) = 0, iff |10*10*t| >=1.

    Is this really the function you want to work with? I guess that is not h(t) from the quote above.

    Anyway I'm not sure what I'm talking about.

    Kind regards
    Rapha
    Follow Math Help Forum on Facebook and Google+

Similar Math Help Forum Discussions

  1. [SOLVED] am I wrong here or is my textbook wrong??
    Posted in the Algebra Forum
    Replies: 5
    Last Post: September 25th 2011, 06:13 PM
  2. What's wrong in this code ?
    Posted in the Math Software Forum
    Replies: 2
    Last Post: March 19th 2010, 05:00 AM
  3. Replies: 6
    Last Post: August 12th 2009, 03:15 AM
  4. wrong code at matlab - meshgrid and 3d plot
    Posted in the Math Software Forum
    Replies: 2
    Last Post: June 30th 2009, 01:17 AM
  5. What is wrong with this code?
    Posted in the LaTeX Help Forum
    Replies: 4
    Last Post: March 7th 2008, 03:54 AM

Search Tags


/mathhelpforum @mathhelpforum